Sign Up

Sign In

Forget Password

Lost your password? Please enter your email address. You will receive a link and will create a new password via email.

You must login to ask question.

“Gradle Version 2.10 is required.” Error

  • 0

As I’ve been using

classpath 'com.android.tools.build:gradle:+'

In the build.gradle file, I got the following error since gradle version 2.10 has been released. The error is :

Warning:Gradle version 2.10 is required. Current version is 2.8. If using the gradle wrapper, try editing the distributionUrl in C:Usersblahblahmyprojectgradlewrappergradle-wrapper.properties to gradle-2.10-all.zip

at first it looks easy to solve by the guide, but when I’d done the change, I got the error again.

I’m using Android Studio 2.0 with the latest Android SDK Tools 24.4.1 and Android SDK Build Tools 23.0.2

I’ve even tried to download Gradle 2.10 and put it manually on android-studiogradle folder, but no luck.

Any help would be appreciated.

Click to rate this post!
[Total: 0 Average: 0]
Share This Post
Share
  1. You need to change File > Settings > Builds,Execution,Deployment > Build Tools > Gradle >Gradle home path

    On Mac OS, change the path in Android Studio > Preferences > Builds,Execution,Deployment > Build Tools > Gradle >Gradle home

    Or set Use default gradle wrapper and edit Projectgradlewrappergradle-wrapper.properties files field distributionUrl like this

    distributionUrl=https://services.gradle.org/distributions/gradle-2.10-all.zip
    • 0
Leave an answer

Leave an answer

Browse

close